1. install the docker desktop
2. open docker desktop, on setting page, click the kubernets, enable kubernets.
3. all certificate are store at C:\Users\username\AppData\Local\Docker\pki
4. hyper-v disk store at C:\Users\seplinus\AppData\Local\Docker\wsl\disk\docker_data.vhdx
5. logs file at C:\ProgramData\DockerDesktop\
6. install folder at C:\Program Files\Docker\Docker
7. iso file at C:\Program Files\Docker\Docker\resources\docker-desktop.iso
8. WSL2 use itself ext4 filesystem(stored in .vhdx), this bring high I/O performance.
through 9P protocol server,Windows access WSL2 file(\\wsl$\),but WSL2 access Windows file(/mnt/c/)performance will be lower. from Windows get WSL file(\\wsl$), reverse at WSL2 access Windows file (/mnt/c/).
windows 10 docker desktop unable to start
# Shut down WSL first
wsl --shutdown
# Unregister the Docker distributions
wsl --unregister docker-desktop
wsl --unregister docker-desktop-data